gemを自分で作成中にエラー

gemを作成中『bundle install』して動作確認しようとしたら下記のエラーがでました。

weather_insight at /Users/xxx/weather_insight did not have a valid gemspec.
This prevents bundler from installing bins or native extensions, but that may not affect its functionality.
The validation message from Rubygems was:
  ["LICENSE.txt", "url_list.rb", "weather_insight.rb"] are not files

『git add --all』を実行したらなおりました。gitのファイルを見てるという事だろうか。

参照:http://stackoverflow.com/questions/20088189/bundle-install-causes-validation-error-after-moving-file